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WHAT IS TABLEAU?

e Data Visualization
Software

* Used for Data Analysis
and many forms of Data
Visualization

* Drag and Drop Interface
for faster navigation
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TYPES OF TABLEAU

Tableau Prep - Data Cleaning Software

Tableau Desktop* — A downloadable application for Data Visualization
(Free for Students)

Tableau Online — Analytics platform fully hosted in the cloud with the ability
to publish dashboards and let anyone view them

Tableau Server — an online platform that allows you to host and manage
Tableau data sources, workbooks, reports, and dashboards

Tableau Reader - Free software tool that allows you to view workbooks and
visualizations made in Tableau Desktop or Public

Tableau Public — Free Visualization Software with Limitations (Visuals can
only be published and not saved or exported locally)

*- Tableau Desktop is the one we will be learning about



Tableau Desktop (free for students for 1 year)
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TABLEAU DESKTOP DOWNLOAD

Fill out this form

Download Tableau Desktop here
Use the email code to verify, then register and begin using

You're almost there!

Are you an instructor? Visit tableau.com/tea
to request your license.

Students at accredited academic institutions worldwide
are eligible for a free one-year license to activate Tableau
Desktop and Tableau Prep. Complete the form below to

confirm your eligibility and unlock your new free license.
You must be 16 years of age or older to request a license.

Country/Region

Personal information

Legal First Name

Legal Last Name

@ salesforce

HE

+i+

t
g tableau

Nhy Tableau v

Products v  Solutions v Resources v Partners v

PRODUCT RELEA

Activate Tableau

Activation
Activate the product.

Enter product key:

S 0000-0000-0000-0000-0000)

If you need help with your product key, please file a support request at
http://www.tableau.com/support/request.

Tableau Desktop

We recommend using the newest maintenance release of this version, which contains additional fixes.

2022.3

[ DOWNLOAD TABLEAU DESKTOP 2022.3 l DOWNLOAD LATEST VERSION (RECOMMENDED)

BACK TO ALL VERSIONS
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https://www.tableau.com/blog/tableau-students-free-access-tableau-desktop
https://www.tableau.com/academic/students
https://www.tableau.com/support/releases/desktop/2022.3

DATA

Import your data from a variety of data sources (SQL, Oracle, SalesForce, JSON, CSV file, etc)
Data is assessed for type automatically and given default assumptions

Blue = Categorical or String Data types (Called Dimensions)

Green = Numeric Data (Called Measures)

These are just the defaults and can be changed as you are crafting your visual

Each visual tells you what it needs to be crafted
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FORMAT

Here is what the Tableau editor consists of
It is a lot, but each part has its own task
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Type of Visual

(Top Right)
- Toolbar icon

Worksheet

Image from Visualization

using Tableau
(slideshare.net)


https://www.slideshare.net/nbgirija/visualization-using-tableau

GOAL

Visualize data quickly and be able to make multiple graphs into a dashboard to answer one or multiple

questions
Filters
Academic Year
College
Gender
Marks
O circle v
HH &
Color Size Label
O;O Q
Detail Tooltip
2
B SUM(True Averag..
Y AVG(Math)
) @NUEGED)
Summary
Count: 651
AVG(Math)
Sum: 3423101
Average: 525.8
Minimum: 2925
Maximum: 800.0
Median: 5238
AVG(Verbal)
Sum: 3641113
Average: 559.3
Minimiim: 2Nk R

2022

v

iii Columns Total Score
= Rows SUM(1)

College Admissions

Explore the distribution of SAT sceres in different colleges

250

200

150

100 P

o

900 1000 1100 1200 1300

1400

*Avg Score 1612

1500 1600

SAT Score

Intro To Tableau

1700

o

1800

1500

2000

2100

o™,

2200

2300

Academic Year

(Al
2013
2014

College

(All)

Arts & Sciences
Business
Communication
Education
Engineering
an -

Gender

(Al
Men
Women

College

B Arts & Sciences
Business

. Communication
Education

M Engineering
Music

>

10



EXAMPLE:
2017 MEN’S
TENNIS DATA



DATA

The data was found at the following website: ATP World Tour tennis data -
Dataset - DataHub - Frictionless Data

In particular, we will be using the 2017 match_scores and match_stats data
found here:

https://datahub.io/sports-data/atp-world-tour-tennis-

data/r/match scores 2017 unindexed.csv

And here:

https://datahub.io/sports-data/atp-world-tour-tennis-

data/r/match stats 2017 unindexed.csv
The easiest way is to just download them to your computer

2022 Intro To Tableau
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https://datahub.io/sports-data/atp-world-tour-tennis-data
https://datahub.io/sports-data/atp-world-tour-tennis-data/r/match_scores_2017_unindexed.csv
https://datahub.io/sports-data/atp-world-tour-tennis-data/r/match_stats_2017_unindexed.csv

STARTING THE PROJECT

Create a new workspace: File > New (Ctrl-N)
Connect to the data source: Data > New Data Source (Ctrl-D)
Under File Source, select more, then CSV file type and select one of the tennis match files.

Then under data source, add another connection and add the other CSV file
Finally, connect them together using Match Id

Connect

forData File name: v | | Other Files (*.twb *.twbx *.tbm *.tds *.tdsx *.tde *.hyper *xIs *xlsx *xIs

Installed Connectors (74) Google Analytics
Lol Gy Other Files (*.twb *.twbx *.tbm *.tds *.tdsx *.tde *.hyper *.xIs *.xIsx *xls
Alibaba AnalyticDB for MySQL Google Cloud SQL
. Alibaba Data Lake Analyt:s Goozle Drive Tableau Workbooks (*.th)
Microsoft Excel Alibaba MaxCompute Hortonworks Hadoop Hive ) Tableau Packaged Workbooks (*.twbx)
- mssan fhens PSS Tableau Data Sources (*.tds)
JSON file Am: Aurora for MySQL IBM DB2
Vams s Amazon EMR Hadoop Hive IBM PDA (Netezz) Databricks Tableau Packaged Data Sources (*.tdsx)
FOFile Amazon Redshit Sy Tableau Data Extracts (*.hyper *.tde)
Spatial file Anaplan Intuit QuickBooks Online D t " . .
Statistical file Apache Drill Kognitio I atorama Excel Workbooks ( xls *xlsx .xlsm)
e Azure Data Lake Storage Gen2 Kyvos ; Denod Microsoft Access Databases (*.mdb *.accdb)
Azure SQL Database LinkedIn Sales Navigator enoado . *
To a Serve Azure Synapse Analytics MapR Hadoop Hive (deprecz Local CUbe Fles( 'cu) =~
Microsot SQL Server Bax MariaDB Dremio Charaer Delimited Files (*.csv)
MySQL Cloudera Hadoop Marketo Text FI l ES (* .tx t)
Databricks MarkLogic

Oracke . icmaett Anayes Semes Dropbox Adobe Portable Document Format (*.pdf)

Amazon Redshift [ WSS [ o4 DU R T, | SN IR NN B I R |

Tableau Server
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VIEWING DATA ATTRIBUTES

First, we need to take a look at the data and see what we can visualize with the information we have.
Once the data is connected,

Under the Data Source tab at the bottom, we can see what attributes the data has

Match Order Winner Name Winner Player Id Winner Slug Loser Name

1 Grigor Dimitrov d875 grigor-dimitrov Kei Nishikori

1 Grigor Dimitrov d875 grigor-dimitrov Milos Raonic

2 Kei Nishikori n552 kei-nishikori Stan Wawrinka

I o - - - - . -
Winner Seed Loser Seed Winner Sets Won Loser Sets Won Winner Games Won
7 2 1
7 1 2 (
2 76(3) 63 2 0



VIEWING DATA ATTRIBUTES

The other way is to look under the data pane, while editing a sheet

Data Analytics < Pages
- - Data Analytics <
B match_stats_2017_unindexed_csv.csv (Multiple C... B
B match_stats_2017_unindexed_csv.csv (Multiple C...

LY Filters 2Y
Tables
Tables
Abc  Match Id A
) # Loser Second Serve Points Total ]
Abc  Match Stats Url Suffix
S Match T Mark # Loser Second Serve Points Won
% Match Time viarks
. # Loser Second Serve Return Total
Me N.
Abc  Measure Names
Automatic v # Loser Second Serve Return Won
4 Loser Aces o0 # Loser Service Games Played
3# Loser Break Points Converted & 4 Loser Service Points Total
o Lo Brosk Pomte St Total Color Size Text oser Service Points Tota
Oser break Foints return fota 4  Loser Service Points Won
# Loser Break Points Saved olo [y 4 Loser Total Points Total
I < Sorve Tt Det Toolt
# Loser Break Points Serve Total eta ooltip 4# Loser Total Points Won
# Loser Double Faults 4 Match Duration
# Loser First Serve Points Total # Tourney Order
3# Loser First Serve Points Won #  Winner Aces
# Loser First Serve Return Total # Winner Break Points Converted
# Loser First Serve Return Won # Winner Break Points Return Total
# Loser First Serves In #  Winner Break Points Saved
# Loser First Serves Total # Winner Break Points Serve Total
# Loser Return Games Played #  Winner Double Faults
# Loser Return Points Total # Winner First Serve Points Total
# Loser Return Points Won #  Winner First Serve Points Won
# Loser Second Serve Points Total # Winner First Serve Return Total
4# Loser Second Serve Points Won #  Winner First Serve Return Won
# Loser Second Serve Return Total #  Winner First Serves In
4 | Acar Sarnnd Sana Ratirn Wan N 4 Winner First Serves Tntal
B Data Source Sheet1l [} H. O B Data Source Sheetl [} H. 0
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ANSWERING QUESTIONS:

Some questions we will try to answer:

* Who won or lost the most matches in 2017?

* What tournaments had the biggest number of upsets?

* Does the return of serve affect the score of how badly
someone loses?



WHO WON OR LOST THE MOST MATCHES IN 20177?:

Top 10 Players who won the most matches in 2017
Make a set of the top 10 Winners by right clicking on Winner Name, Create > Set

Change name to “Top 10 Winners”, then under the Top tab, we change it to top 10 by Winner Games
(Count)

Simply drag Winner Name into the Column and then drag Count (change Aggregation type) of Winner
Games Won into the Row

Then filter using the set we created

Pages lii Columns Winner Name =
:= Rows CNT(Winner Games ..

Filters

IN/OUT(Top10.. @

Top 10 Winners
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WHO WON OR LOST THE MOST MATCHES IN 20177?:

Pages iii Columns Winner Name =

‘= Rows CNT(Winner Games ..

Top 10 Winners

Filters

IN/OUT(Top10.. @

Winner Name

2N
£y

(&)

(&)

Marks
il Automatic v 60
- &
Color Size Label I .
= 50
o
000 o] Em
Detail | Tooltip g
S AN
S 40
|-
v
c
=
% | I I
5]
-
c
3
o
o

Rafael Alexander Roger David Roberto Dominic  Grigor Marin Adrian Ma Diego Sch

Nadal Zverey Federer Goffin lautist. Thiem  Dimitrov Cilic nnarino wartzman
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WHO WON OR LOST THE MOST MATCHES IN 20177?:

Players who lost more than 20 matches in 2017
Create new sheet

Simply drag Loser Name into the Column and then drag Count (change Aggregation type) of Loser Games

Won into the Row
Then filter based on the number of Loser Games Won, at least 20

Filter [Count of Loser Games Won]

— = |
Range of values Atleast At most
Pages iii Columns Loser Name =
= At least
‘= Rows CNT(Loser Games W..
Filters 2
At Least 20 Losses a

CNT(Loser Games .. 1

Show: Only Relevant Values

Reset

2022 Intro To Tableau
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Cancel Apply

19



D
Loser Name

NT(Loser Games W..
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WHAT TOURNAMENTS HAD THE BIGGEST NUMBER OF
UPSETS?

Define an upset: when a lower seeded player beats a higher seed (Lower value of seed is better e.g. 1 is

the best seed)
First, create a calculated field, seeing where upsets occur (Winner Seed > Loser Seed)
Then, we have to handle null values in the data, usually null means the player is unranked.

If a loser is unranked, it’s not an upset. If the winner is unranked, it is
So, we get the following formula:

If ISNULL ( ) THEN FALSE
ELSE IF ISNULL ( ) THEN TRUE

ELSE > END END

1e calculation is valid.



WHAT TOURNAMENTS HAD THE BIGGEST NUMBER OF
UPSETS?

Then, drag Tournament names to columns, and (Count) of Winner Games Won(Doesn’t matter what field)
Filter based on the newly created upset field, and by the count if you don’t want all tournaments

Filter [Upset] X

General Condition Top

@® Select from list O Custom value list O Use all

Pages iii Columns Tourney Slug = L Fase
True
Rows CNT(Winner Games ..

Tournament Upsets

Filters

CNT(Winner Games .. .

All None [] Exdude

Summary

Field: [Upset]
Selection: Selected 1 of 2 values

Condition: None
Limit: None

Reset Cancel Apply
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WHAT TOURNAMENTS HAD THE BIGGEST NUMBER OF
UPSETS?

Pages jii Columns Tourney Slug =

Rows CNT(Winner Games ..

Tournament Upsets

Filters

CNT(Winner Games .. . Tourney Slug

Marks 60
ol Automatic v
50
NS
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o;o Q
Detail |Tooltip . I I
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DOES THE RETURN OF SERVE AFFECT THE SCORE OF HOW

2022

BADLY SOMEONE LOSES?

Define how what we measure for return of serve:
In the data, we have loser return points won, loser first serve return won, and loser second serve

return won. (All are values that should be converted to percentages by dividing by total)

Create those calculated fields: [Return won] / [Return total]
Then, measures of how badly someone loss can be how many games they were able to win, how

long the match was played, or how many points they won.
So, we can visualize these using scatterplots

@ @ .
ut ’ o @ .’o' o¢
ke ... o e o x’.e
¢ o %9 * ) ) 09,0
o o o s o - 0 o [ °
fc* " o 3ot b, o 3
o
... .. a. Le¥ed ® .". ? .. o ® @ i)
& o®
@ : ® 0.. ‘0‘ ° ® o
& . ° ® .‘. ® o, 0 . L O
o il ® o o o

null / no relationship strong, non-linear
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DOES THE RETURN OF SERVE AFFECT THE SCORE OF HOW
BADLY SOMEONE LOSES?

Drag all the percentages we just calculated into columns
Then, drag the values we want to compare against into rows
And filter out any null values in the data

Special Values for [Loser Second Serve Return Percent] X

The Loser Second Serve Return Percent axis has at least 11 null values.

Pages iii Columns Loser Return Points .. Loser First Serve Ret.. ]| Loser Second Serve .. What do you want to do?
= Rows Match Duration Loser Total Points W.. )
Filter data

Excdude the spedal values from the view and calculations.

e Returning Stats

- Show data at default position

. WP
Show the spedal values at a default position on the axis. For
example, Null values are shown at 0.
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DOES THE RETURN OF SERVE AFFECT THE SCORE OF HOW
BADLY SOMEONE LOSES?

Pages iii Columns Loser Return Points .. Loser First Serve Ret.. Loser Second Serve ..
i= Rows Match Duration Loser Total Points W..
Filters

Returning Stats

Loser Second Serve ..

£ 30
=
Marks 8 20 \
E
g Tl '
o0 {1
28 Al 2 4 i
P : ‘.i.’
282 LoserReturnP... =
0
22 Loser First Serv... 200
s
29 Loser Second ... S
» 200
3
— s a
a¢ Automatic 5 =
v
£ 100
- & =
Color Size Label 0
5
oo By, 29 = 200
Detail | |Tooltip| | Shape e E
°
b SUM(Loser Ga.. el
s 100 a
Ll
o
-
'
L)
w
[=] n
S o
0.0 0.2 04 0 0.8(0.0 0.2 04 0.0 0.5 10

Loser Return Points Percent Loser First Serve Return Percent Loser Second Serve Return Percent

Intro To Tableau

26



EXPORTING
RESULTS/
CONCLUDING
REMARKS



SAVING YOUR WORKBOOK

You can save your graphs for later editing as Tableau Workbook (.twb) or Tableau Packaged Workbook

(.twbx)
The main difference is that the Packaged Workbook includes your data along with the graphs, so you can

run it on another computer without needing access to the data.
While a Workbook is quicker to save and edit
Simply use File > Save As

File name: | TennisWorkbook iy

Save as type: | Tableau Workbook (*.twb) v

Tableau Workbook (*.twb)
Tableau Packaged Workbook (*.twbx)
~ Hide Folders . .

2022 Intro To Tableau 28



EXPORT TO IMAGE OR OTHER

You can export your graphs to an image by using

Worksheet > Export > Image

Or you can download as a PowerPoint with

File > Export as PowerPoint
Or as a PDF
File > Print to PDF

File Data Worksheet Dashboard Story Analysis Map Format Server

Data Worksheet Dashboard

New
Open...

Close

Save
Save As...

Revert to Saved

¥ @ ooo -
B &t New Worksheet Ctrl+M - o s Export As Version...
Export Packaged Workbook...
» P 9
Data Eo] - -
Export 4 |magem EXPOltAS PowerPoint...
= matck
© — ' Data... Show Start Page
Actions... Ctrl+Shift+A Cr?fitjito iz
File name: | Some Graph o
Save as type:

» Hide Folders

Portable Network Graphics (*.png)
Scalable Vector Graphics (*.svg)

2022
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Analysis | File Data Worksheet Dashboard Story

Ctrl+N
Ctrl+0 Open...

New

=T

Close

Ctrl+S Save

Save As...

F12 Revert to Saved

Export As Version...

Export Packaged Workbook...
Export As PowerPoint...

Ctrl+2 Show Start Page

Share...

Paste
Import Workbook...

Page Setup...
Print...
Print to PDF...
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CONCLUDING REMARKS

Tableau is a quick and effective data
visualization tool, which can be used to
quickly analyze and see data. The main
drawbacks are taking time to learn how to use
the tools that Tableau provides and getting
used to the drag and drop style of building
graphs. Creating a basic graph usually takes a
lot less time than coding libraries such as D3
and Vega but can require more time with
online tutorials to change small parts.
Although not shown here, Tableau offers a
wide variety of graphs that can be generated
and is very useful for visualizing many types of
data. Then, the visuals can be put into a
dashboard for easy access in the same spot.



THANK YOU

Tanner Finken

finkent@arizona.edu
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